Increased error rate in China region
Incident Report for Faria Education Group
Resolved
This incident has been resolved.
Posted Feb 24, 2020 - 12:47 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 24, 2020 - 12:16 UTC
Identified
The issue has been identified and we are working to resolve it shortly.
Posted Feb 24, 2020 - 10:02 UTC
This incident affected: ManageBac.